Project 1999

Go Back   Project 1999 > General Community > Technical Discussion

Reply
 
Thread Tools Display Modes
  #501  
Old 02-10-2019, 10:53 AM
samkds samkds is offline
Aviak


Join Date: Jun 2012
Posts: 53
Unhappy

Another patch another crash. Unable to get passed the launcher I get a gui error or something.

Any solution? Using a wineskin and I have no idea how this all works.
Reply With Quote
  #502  
Old 02-10-2019, 11:18 AM
samkds samkds is offline
Aviak


Join Date: Jun 2012
Posts: 53
Default

Exact error upon launching of the wineskin is: Error in your GUI XML files. Check UIErrors.txt
Reply With Quote
  #503  
Old 02-10-2019, 11:52 AM
kingpinner kingpinner is offline
Aviak


Join Date: Dec 2018
Posts: 68
Default

Quote:
Originally Posted by samkds [You must be logged in to view images. Log in or Register.]
Exact error upon launching of the wineskin is: Error in your GUI XML files. Check UIErrors.txt
I'm having the same issue on Mac after downloading P99Files46 and adding to the EQ directory.

Exact error message shows:

Error in XML
Error in your GUI XML files. Check UIErrors.txt

The UIErrors.txt reads as such:

UIErrorLog created at Sun Feb 10 09:36:08 2019
[Sun Feb 10 09:36:08 2019] Warning: file EQLSUI.xml not found in directory UIFiles\default\. Attempting to use file from Default skin.
[Sun Feb 10 09:36:08 2019] Couldn't open or read UIFiles\default\EQLSUI.xml
[Sun Feb 10 09:36:08 2019] Error reading XML.
[Sun Feb 10 09:36:08 2019] Error loading skin: loading default skin instead.
[Sun Feb 10 09:36:08 2019] Warning: file EQLSUI.xml not found in directory UIFiles\default\. Attempting to use file from Default skin.
[Sun Feb 10 09:36:08 2019] Couldn't open or read UIFiles\default\EQLSUI.xml
[Sun Feb 10 09:36:08 2019] Error reading XML.
Reply With Quote
  #504  
Old 02-10-2019, 11:54 AM
samkds samkds is offline
Aviak


Join Date: Jun 2012
Posts: 53
Default

Ok this is what worked.

I reinstalled the game fresh. And one by one re copied every patch file one by one. The ones in folders I went in each and copied the content of it instead of the whole folder. Worked first time.
Reply With Quote
  #505  
Old 02-10-2019, 12:06 PM
kingpinner kingpinner is offline
Aviak


Join Date: Dec 2018
Posts: 68
Default

Quote:
Originally Posted by samkds [You must be logged in to view images. Log in or Register.]
Ok this is what worked.

I reinstalled the game fresh. And one by one re copied every patch file one by one. The ones in folders I went in each and copied the content of it instead of the whole folder. Worked first time.
Did you delete your EQ files first then reinstall fresh? Its been so long since i installed this I don't remember what steps i took lol
Reply With Quote
  #506  
Old 02-10-2019, 12:08 PM
samkds samkds is offline
Aviak


Join Date: Jun 2012
Posts: 53
Default

Yup i installed the package from Vile in another thread or this one canít remember
Reply With Quote
  #507  
Old 02-10-2019, 08:27 PM
Chango Chango is offline
Large Rat


Join Date: Feb 2018
Posts: 7
Default

What directory do these files go to on Mac?
Reply With Quote
  #508  
Old 02-12-2019, 05:12 PM
spiz spiz is offline
Large Bat


Join Date: Feb 2015
Posts: 10
Default

Quote:
Originally Posted by kingpinner [You must be logged in to view images. Log in or Register.]
I'm having the same issue on Mac after downloading P99Files46 and adding to the EQ directory.

Exact error message shows:

Error in XML
Error in your GUI XML files. Check UIErrors.txt

The UIErrors.txt reads as such:

UIErrorLog created at Sun Feb 10 09:36:08 2019
[Sun Feb 10 09:36:08 2019] Warning: file EQLSUI.xml not found in directory UIFiles\default\. Attempting to use file from Default skin.
[Sun Feb 10 09:36:08 2019] Couldn't open or read UIFiles\default\EQLSUI.xml
[Sun Feb 10 09:36:08 2019] Error reading XML.
[Sun Feb 10 09:36:08 2019] Error loading skin: loading default skin instead.
[Sun Feb 10 09:36:08 2019] Warning: file EQLSUI.xml not found in directory UIFiles\default\. Attempting to use file from Default skin.
[Sun Feb 10 09:36:08 2019] Couldn't open or read UIFiles\default\EQLSUI.xml
[Sun Feb 10 09:36:08 2019] Error reading XML.
I had this problem, too. Basically, we all nuked the contents of our existing ui/default directory.

I believe that, on a Mac, when you drag a source directory to an existing target directory the system effectively deletes the target directory and then copies over the source directory.

This is different from a Windows machine. In Windows, when you copy a source directory to an existing target directory, the system ADDS the source directory's files to the target directory, prompting to replace / skip / etc any existing files, but keeping any files that were already there.

I fixed my install by finding the original ui/default files and copying the new files over correctly, then I copied the patch's files over rather than the directory. The game works correctly for me now.

SOLUTION
1. Download the default game UI files. You can get the link a .zip of these files in this post: https://www.project1999.com/forums/s...70&postcount=5

2. Unzip these default UI files. The files will unzip into a default directory.

3. Copy the files in this default directory to your game's ui/default directory.

4. Go back to the new patch files that you previously downloaded and find the ui/default directory within. Select all the files in that directory.

5. Copy them by going to File >> Copy x items located in Finder's top menu.

6. Go to your game's ui/default directory and paste them there, overwriting as needed.
Reply With Quote
  #509  
Old 02-19-2019, 04:27 PM
Atychiphobia Atychiphobia is offline
Scrawny Gnoll


Join Date: Dec 2018
Posts: 25
Default

Quote:
Originally Posted by samkds [You must be logged in to view images. Log in or Register.]
Ok this is what worked.

I reinstalled the game fresh. And one by one re copied every patch file one by one. The ones in folders I went in each and copied the content of it instead of the whole folder. Worked first time.
This worked for me, thanks!

Download the V45 files from Vile at page 47 or something and do this.

Cheers!
Reply With Quote
  #510  
Old 02-19-2019, 04:46 PM
Bache Bache is offline
Orc


Join Date: Nov 2018
Posts: 32
Default

Because you are all owning the game, here is the linkg

https://drive.google.com/open?id=1MZ...52Pxa-GL0NwvrZ

thanks !
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 06:29 PM.


Everquest is a registered trademark of Daybreak Game Company LLC.
Project 1999 is not associated or affiliated in any way with Daybreak Game Company LLC.
Powered by vBulletin®
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.