Project 1999

Go Back   Project 1999 > General Community > Technical Discussion

Reply
 
Thread Tools Display Modes
  #1  
Old 09-15-2015, 11:39 PM
andrewjk andrewjk is offline
Skeleton


Join Date: May 2015
Posts: 16
Send a message via Skype™ to andrewjk
Default Error in your GUI XML files

I havent played in a while come back and find an Error Code Sp-1 on the character screen.

I thin went to this thread

https://www.project1999.com/forums/s...+file+outdated

I replaced the files with the zip someone posted. Now Im getting "Error in your GUI XML files.CHeck uierrors.txt. which reads:-

UIErrorLog created at Tue Sep 15 21:33:14 2015
[Tue Sep 15 21:33:14 2015] Warning: file EQLSUI.xml not found in directory UIFiles\default\. Attempting to use file from Default skin.
[Tue Sep 15 21:33:14 2015] Couldn't open or read UIFiles\default\EQLSUI.xml
[Tue Sep 15 21:33:14 2015] Error reading XML.
[Tue Sep 15 21:33:14 2015] Error loading skin: loading default skin instead.
[Tue Sep 15 21:33:14 2015] Warning: file EQLSUI.xml not found in directory UIFiles\default\. Attempting to use file from Default skin.
[Tue Sep 15 21:33:14 2015] Couldn't open or read UIFiles\default\EQLSUI.xml
[Tue Sep 15 21:33:14 2015] Error reading XML.

Can someone help please
Reply With Quote
  #2  
Old 09-16-2015, 12:25 AM
Sorn Sorn is offline
Planar Protector

Sorn's Avatar

Join Date: Jun 2010
Location: Anywhere but Plane of Mischief
Posts: 2,099
Default

Can you check in uifiles > default to make sure you did not accidentally overwrite and delete the default ui files when making changes?

The usual behavior of the client is like so:
> Check what custom UI is being used (via loadskin)
> Check UI files for everything the client needs
> If some files are missing, go into default UI to get the files (ex: looks for EQUI_MerchantWindow.xml in the custom ui folder, if it isn't there, go into default to find the same file.)
> If default UI is missing files, produce error (and possibly shut the game down)
__________________
Reply With Quote
  #3  
Old 09-16-2015, 01:23 AM
phacemeltar phacemeltar is offline
Planar Protector

phacemeltar's Avatar

Join Date: Jun 2013
Location: western hemisphere
Posts: 1,612
Default

which ui are you using?
__________________
Reply With Quote
  #4  
Old 09-16-2015, 05:22 AM
andrewjk andrewjk is offline
Skeleton


Join Date: May 2015
Posts: 16
Send a message via Skype™ to andrewjk
Default

I cant find a EQUI_MerchantWindow.xml anywhere.

Im using the default uifiles folder it contains the following:-

classic_pieces01
EQLS_background_01
EQLS_background_02
EQLS_background_03
EQLS_background_04
EQLS_background_05
EQLS_background_06
EQUI_Animations
EQUI_BankWnd
EQUI_CastSpellWnd
EQUI_GemsGameWnd
WQUI_HotButtonWnd
gemicons01
gemicons02
gemicons03
spells01
spells02
spells03
spells04
spells05
spells06
spells07
window_pieces01
window_pieces02

I deleted/replaced the files/folders that came in the zipfile in that thread (link posted)

I appreciate you helping. I'm at a loss.
Reply With Quote
  #5  
Old 09-16-2015, 10:33 AM
Sorn Sorn is offline
Planar Protector

Sorn's Avatar

Join Date: Jun 2010
Location: Anywhere but Plane of Mischief
Posts: 2,099
Default

Okay, it looks like you replaced the entire folder and lost all your default uifiles. You can get a copy of the full UI from here.

Just download, unzip, and place the contents in the default folder. Replace everything. Then, when you apply the new files, try to merge rather than outright replace the folder, or drag and drop the files into the open folder manually so you don't lose the files that don't need updates.
__________________
Reply With Quote
  #6  
Old 09-20-2015, 01:43 PM
andrewjk andrewjk is offline
Skeleton


Join Date: May 2015
Posts: 16
Send a message via Skype™ to andrewjk
Default

It worked thank you so much!
Reply With Quote
  #7  
Old 11-07-2015, 09:22 AM
Grimpond Grimpond is offline
Decaying Skeleton


Join Date: Nov 2015
Posts: 2
Default

Hi I'm having the exact same error,
Error in your GUI XML files. Check UIErrors.txt" however I am unable to even locate my UIErrors.txt file to even begin to see what's going wrong.

Can anyone help?

Thanks!
Reply With Quote
  #8  
Old 11-07-2015, 09:39 AM
Grimpond Grimpond is offline
Decaying Skeleton


Join Date: Nov 2015
Posts: 2
Default Same Error But no UIErrorlog.txt

Hi, I get this same error, however I don't have an UIErrorlog.txt to even begin to troubleshoot.

Does anyone have any pointers for me?

Thanks!
Reply With Quote
  #9  
Old 04-04-2019, 01:27 AM
scifo76 scifo76 is offline
Kobold

scifo76's Avatar

Join Date: Feb 2016
Posts: 116
Default

Sorry for bumping this old thread, but today I got exactly the same error message when trying to log in. First time I've ever seen this error message, been playing the game for 3 years and haven't done any software/hardware changes lately.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 01:32 PM.


Everquest is a registered trademark of Daybreak Game Company LLC.
Project 1999 is not associated or affiliated in any way with Daybreak Game Company LLC.
Powered by vBulletin®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.